Click to call unavailable
Incident Report for iAdvize (SD)
Resolved
After an intervention of our technical team, the click to call channel is now working properly.

Thank you for your patience.
Posted Mar 14, 2017 - 17:34 CET
Investigating
We are experiencing an issue on the click to call channel.
A message "An application Error has occured" is played on the agent's side.
Our technical team is working on it to identify and resolve this issue.
Posted Mar 14, 2017 - 17:09 CET