The statistics are currently unavailable
Incident Report for iAdvize (SD)
Resolved
All the statistics are back to normal. Thank you for your patience.
Posted Mar 13, 2017 - 16:15 CET
Identified
The service is going to be restarted to get the statistics back.
Posted Mar 13, 2017 - 15:47 CET