Unable to connect to the desk
Incident Report for iAdvize (SD)
Resolved
The problem is now solved.

Thank you for your patience and understanding
Posted May 25, 2023 - 15:17 CEST
Identified
We have identified a problem impacting the loading of the desk. We are actively working to resolve it.
Posted May 25, 2023 - 15:11 CEST
This incident affected: Conversation Panel (Login).