Service disruption
Incident Report for iAdvize (SD)
Resolved
All our services are now operating normally.
Posted Feb 12, 2024 - 10:49 CET
Investigating
There is currently an incident impacting our services.

We are working to restore the service and will update you as we learn more.
Posted Feb 12, 2024 - 09:51 CET
This incident affected: Administration (Login, Engagement settings, Distribution settings, Channel settings, Users management, Statistics, Sending email).